Differences Between Batch Processor and NeuroShell 2

Top  Previous  Next

The Batch Processor has been designed to work very closely with NeuroShell 2, but, in order to run multiple problems in batch mode, some minor differences do exist.  These differences are explained below.

 

1.

The Batch Processor will copy or rename data files from one problem name to another for training and applying neural networks.  If the files were copied, they will exist when execution of the session is complete.  If the files were renamed, they will be renamed back to their original name.

           

    For example, consider our weather problem.  Suppose you have a base problem called WEATHER and you have 3 other alias problems called WEATHER1, WEATHER2, and WEATHER3.  All of these problems use the same data files from the base problem WEATHER.  Therefore, when WEATHER1 begins to execute, the data files for WEATHER will be renamed to WEATHER1.  Once WEATHER1 has finished execution, the files will then be renamed back to WEATHER.  This process is repeated for WEATHER2 and WEATHER3.

           

    If the problems WEATHER1 through WEATHER3 existed in a different directory than WEATHER, then the WEATHER data files would be copied to the respective directories of WEATHER1 through WEATHER3.  To speed-up execution time and avoid having duplicate files, try keeping your alias problems in the same directory as your base problem.

           

2.

The NeuroShell 2 interface is replaced by the Batch Processor interface.  Moving from module to module is done by double-clicking in a cell of the Batch Grid, as opposed to double-clicking icons in the NeuroShell 2 interface.

           

3.

File importing, preprocessing and postprocessing capabilities, such as Rules, Symbol Translate, and Test Set Extract, may be accessed from the Tools Menu on a file-by-file basis. If you own the Market Indicator Package or the Race Handicapping Package,  they may also be accessed from the Tools Menu.  However, unlike in NeuroShell 2, you will have to use the File menu to select the pattern file to be processed.

           

4.

When training or applying neural networks, any error messages or statistical output is written in a file called <Session Name>.ERR, where Session Name is the name of the current session.  This is a text file and it can be loaded into the Batch Processor Message Pane or into the Windows notepad for review.

           

5.

To avoid possible file name conflicts when applying your neural networks to new data files, the results of the Apply module will be files with extensions of .OT0 to .OT9 instead of the .OUT extension used in NeuroShell 2.  This is because the option allows you to apply your neural network, as well as variations of that network, to up to ten different data files.

 

    For example, let’s use the weather problem again.  Suppose you have two data files called WEATHER.PAT and WEATHER.PRO to which you want to apply the neural network.  During the execution of the base problem WEATHER, the output file generated from WEATHER.PAT would be WEATHER.OT0, and the output file generated from WEATHER.PRO would be WEATHER.OT1.