Correlation Scatter Plot Detail

Correlation Scatter Plot Detail

Top 

Correlation Scatter Plot Detail

Use this module to make a scatter plot of one variable against another through all patterns. The module computes the linear correlation coefficient between two variables.

 

The linear correlation coefficient is a statistical measure of the strength of the relationship between the two characteristics that are graphed in the scatter plot.   The r coefficient can range from -1 to +1 .  The closer r is to 1, the stronger the positive linear relationship, and the closer r is to -1, the stronger the negative linear relationship.  When r is near 0 there is no linear relationship.

 

Obviously you are going to get better network predictions if  the network inputs are correlated with network outputs.  However, don't assume that the network can't make good predictions if the input variables are not correlated with the output because networks are capable of finding patterns amongst several variables, none of which is highly correlated with the output but which together form a pattern which uniquely determines the output.

 

You may also want to use a scatter plot to create a graph of actual versus predicted values and to compute a linear correlation coefficient to see how well your network is predicting.

 

Choose the two variables you wish to compare by clicking on the variables in the scroll box.  Hit the Control key before clicking on the second variable.  Click on the Graph button to display the graph.

 

Use the File Menu to select a file to graph, to print the graph, or write it to a file.  Also use this menu to view the pattern file.

 

Use the Edit Menu to copy the graph to the clipboard or to clear the graph.

 

Use the Graph Menu to select the type of graph:  Variable(s) Across All Patterns, Variable(s) Across N Patterns; Variable Sets in a Pattern, Two Variables Against Each Other, or High Low Close.

 

Use the Options Menu to decide whether to hide the Variable/Column List and display a larger graph,  to change Graphics Attributes, Graph Scaling or to change Data Set Colors/Styles.