Data Entry (Datagrid) Detail

Top 

Data Entry (Datagrid) Detail

_bm1Use the Data Entry module or the Datagrid to enter data directly into NeuroShell 2 format or to view files after network processing.  This is a spreadsheet-like data entry form that allows you to cut, paste, and move data, but it is not a fully functional spreadsheet. The Datagrid was designed for use with small files only as it becomes slower and less efficient with large files.   If you are working with large files, we suggest using your regular spreadsheet and reading the results into NeuroShell 2 using the Spreadsheet File Import module.  You may also use the NeuroShell 2 Main Menu Options to select a spreadsheet program that you would like to use as an alternate data entry and viewing mechanism within NeuroShell 2.  Refer to How to Use NeuroShell 2 for details. All of the data for a pattern should be entered on the same row.  

 

Variable Names

If you want to include the names of variables with your data, type in the number of the row that includes the names of variables in the edit box at the top of the screen.  Click on the row number and use the Format Menu to change the data type to text (see below for details). NeuroShell 2 will then use these names as variable/column names when they are displayed in the modules.  It is suggested that you give each column a unique name to avoid confusion when working with the data, e.g. defining network inputs and outputs.

 

If you don't want to include the names of variables in the data, leave the edit box blank.  NeuroShell 2 will use column identifiers such as C1, C2, etc. as the names of the variables.

 

The Datagrid form displays the current grid size, i.e., the number of rows and columns.  This number may be useful if you want to resize the Datagrid with the Format Menu's Resize Datagrid option.

 

File Menu

Use the File Menu to either create a new file, load an existing file, or interrupt file loading.  Also use the File Menu to save the file under the existing problem name once you have made changes or save the file under a different problem name with the Save As option.

 

The Print option allows you to print the file that is currently loaded in the Datagrid.  When you select this option, a window will pop up that will allow you to click on check boxes to Print Column Headers, Print Row Headers, Print Border, and/or Print grid lines.  The window also allows you to type in measurements in inches for the top, bottom, left, and right margins. You can also print only selected cells by clicking on the mouse to blacken the cells.

 

Edit Menu

The left/right arrow keys end edit box at the top of the screen controls what the left and right arrow keys do when working within the Datagrid.  If you check the box by clicking the mouse, you may use either the left or right arrow key to complete data entry in a cell and jump to the next cell.  If the box is not checked, the left and right edit keys only move within the cell.  You need to strike Enter to end the edit before continuing to the next cell.

 

The Datagrid operates with conventional mouse editing techniques.  Hold down the left mouse button and drag the mouse over cells you want to edit  (they will be highlighted or blackened).  Use the Edit Menu to cut, copy, paste, or clear the cells.

 

Click the mouse on the column letter or name to highlight an entire column.  Click on row numbers to highlight an entire row.  Use the Edit Menu to cut, copy, paste, or clear entire rows or columns.

 

If you copy a range of cells and want to paste them back into the Datagrid, you only have to use the mouse to blacken the upper left cell of the paste area in order to paste the entire range of cells.  If you paste cells containing numbers into cells that are formatted as text type, you need to change the cell format to numeric before you can complete the paste.  (See the Format Menu for details.)

 

Use the Edit Menu to insert a row or column, or to delete row(s) or column(s).

 

Formulas

The Edit Menu allows you to copy and paste formulas in the Datagrid. Formulas may be used by a row, column, or cell in the Datagrid.  All formulas should begin with the = sign and need to be included in numeric type cells rather than text cells.  For example, to add together the contents of cell A2 and B2, the correct formula would be:  =(A2+B2).  The Wild Card character (#) may be used for rows and columns, for example, =A#+B#.  This would allow the active row to be used in the calculation, and the formula can be pasted down an entire column.

 

Note:  Even though formulas may be displayed in the Datagrid, only the values computed by the formula will be available for processing by the network.

 

Available Functions:              

Add(a,b)                              

If (a, b, c)                              

ISEMPTY(Coord)              

NEG(Coord)                              

ABS(Coord)                              

NOT(Coord)                              

PMT(Amt, Interest, Term,              

TermsPerYear)

ROUNDUP(Value)              

ROUND(Value)                              

TRUNCATE(Value)              

                           

Valid Operators:

+ Addition

- Subtraction

^ Power operator

* Multiplication

/ Division

& Logical And Logical Or

! Negation

> Greater than

< Less than

= Equality

 

Format Menu

You may use the Format Menu to change column width:

To change column width

1.  Select Double Column Width or Half Column Width from the Format Menu or

2.  Use a mouse to drag the vertical bar between columns in the first row.

 

To change row width

Use a mouse to drag the horizontal bar above or below the row numbers column to change row width.

 

To resize datagrid

Select the Resize Datagrid option.  An edit box is displayed which allows you to type in the total number of rows/columns you wish to be included in the Datagrid.  If you have resized the Datagrid, you need to save the file in order to preserve the new dimensions.

 

Data Types

The Format Menu allows you to select different data types for columns and rows.

 

Data needs to be in numeric format by the time it is processed by the network. The network does allow text and date data to be included in the data file for label purposes, and there is also a module called Symbol Translate which will convert alphanumeric data or symbols into numeric data.

 

Note:  Because an * is used to indicate rows to be skipped during training, make sure that your data files do not contain an asterisk in an input.  Otherwise, NeuroShell 2 will ignore the data in that row when you start training.

 

The default data type for each cell is number with decimal places. To change the data type, click on a column letter or row number and then use the Format Menu to select either a numeric, text, or date data type. When the Datagrid is first opened for a new problem, the first row includes "dummy" column names of Name 1, Name 2, and Name 3 and the cell type has been set to text.

 

Numeric

Plain - Only numbers in integer format are displayed in the cells.

Money - Numbers with a currency symbol are displayed in the cells. The currency format is the one chosen in the Windows Control Panel and may be changed in the Control Panel.

Thousands Separated - A comma is placed between a number in the thousands place and the rest of the number. Two decimal places are displayed.  The separator may not be a comma in some countries depending upon settings chosen in the Windows Control Panel.

Money Separated - Numbers with a currency symbol appear in the cells and a comma is placed between a number in the thousands place and the rest of the number. The currency format is the one chosen in the Windows Control Panel and may be changed in the Control Panel.

Decimal Places - Enter the number of places to the right of the decimal that you want to display in each cell in the edit box. The maximum number of places is 20.

 

Text

When you select Text, a horizontal menu appears from which you can select an option to display the text in the left side of the cell (Left Aligned) or in the right side of the cell (Right Aligned).

 

Date

When you select Date, the data in each cell is displayed in the date format set in the Windows Control Panel and may be changed in the Control Panel.  When the edit box is in a cell with a date data type, double click the mouse or strike the F4 key to display a calendar from which you may select a date.

 

 

Datagrid Function Keys

Function keys make it easier to move within the spreadsheet.  The following list details the keys and their use within the NeuroShell 2 Datagrid.

 

Key                Function

Up Arrow         Activate the cell above the current

                   active cell.

Down Arrow     Activate the cell below the current

                   active cell.

Right Arrow     Activate the cell to the right of the

                   current active cell.

Left Arrow       Activate the cell to the left of the

                   current active cell.

Shift-Arrow      Selects cells as you click any arrow

                    key.

PgUp               Move the active cell one page up.

PgDn               Move the active cell one page down.

Ctrl-PgUp         Move the active cell one page to the

                    left.

Ctrl-PgDn         Move the active cell one page to the

                    right.

Home               Move the active cell to the first cell in

                     the row.

End                  Move the active cell to the last

                     column that has data, staying within

                     the current row.

Ctrl-Home         Move the active cell to row one,

                     column one.

Ctrl-End            Move the active cell to the last row

                     and column that contains data.

Shift-End           Selects cells from the active cell to

                      the last column that contains data.

                      Works with multiple rows.

Shift-Home         Selects cells from the active cell to

                      column one. Works with multiple

                      rows.

Shift-PgDn         Selects active cell(s) and all cells

                      down the column(s).

Enter                 If edit mode is on, edit mode will be

                      turned off.

Esc                   If edit mode is on, edit mode will be

                      turned off and the previous cell value

                      will replace the new value.

Delete                If edit mode is on, the cell value will

                      be cleared.

F3                     If the cell type is data or time and

                      edit mode is on, the current data or

                      time will be placed within the cell.

F4                     If the cell type is data and edit mode

                      is on, a pop-up calendar will be

                      displayed for choosing a date.

Tab                    Move to the next cell.  The order is

                      right, then down.

Shift-Tab            Move to the previous cell.  The order

                      is left, then up.

Use the Format Menu to resize the entire grid.