How to Use NeuroShell 2

How to Use NeuroShell 2

Top  Previous  Next

 

Starting NeuroShell 2

Click on the NeuroShell 2 "brain" icon that should have been placed in the NeuroShell 2 Program Group when you installed the program. The NeuroShell 2 Main menu will be displayed.  Note that is a very narrow menu bar above and detached from the warning screen.  Select the File Menu from the Main menu and either create a new problem name or open an existing problem name.

 

Problem Names

Each problem refers to a neural network application.  During various stages of processing the problem, NeuroShell 2 will build different files associated with the application.  The names of the files all begin with the same problem name (max of 8 characters) and end with different appropriate extensions.

 

File Menu:

New Problem: Allows you to start a new problem in NeuroShell 2 by typing the name of the problem or the name of the problem's description (.DSC) file.

 

Open Problem: Allows you to select an existing problem by selecting the associated description file previously saved.  You can select the file or type its name.  If you type it, the .DSC extension is not required.  You may add or change the problem description anytime the problem description box is displayed.

 

The Main Menu Window

The Main Menu Window gives you the option of using NeuroShell 2 three different ways:  the Beginner's System, the Advanced System, and the RunTime System.  All three systems are constructed of subprograms called "modules" and each module is represented by an icon.  Most users should start with the Beginner's System first.

 

_bm23

 

To use a module, double click the left mouse button on the icon that represents that module.  To receive help on how to use a module, single click on the icon and then select Current Context from the Help Menu.

 

_bm24

The Beginner's System

 

When a group of icons appears on the screen, the order of operations is to work from left to right.  If icons appear in a column, work from top to bottom.  Note that you may not have to use all of the icons that appear on a screen in order to create a working neural network application. Many of the modules are optional depending upon the type of application you are creating.

 

_bm25

The Advanced System

 

Main Menu Options

NeuroShell 2 offers several main menu options which enable you to work with files within NeuroShell 2 and with external programs.

 

File Menu:

New Problem: Allows you to start a new problem in NeuroShell 2 by typing the name of the problem or the name of the problem’s description (.DSC) file.

 

Open Problem: Allows you to select an existing problem by selecting the associated description file.  You can select the file or type its name.  If you type it, the .DSC extension is not required.

 

Save Problem: Saves the description file for the current problem under the same name you entered when you created the problem.

 

Save Problem As: Saves the description file for the current problem under a new name you enter.  You will then be given the opportunity to copy all other files in the existing problem, giving them the new name.

 

Transfer info to another problem: The transfer option allows you to select some or all of the files from the current NeuroShell 2 problem and copy them to another problem.  This option is useful when you want to create an application similar to the current problem and you want to make use of existing files, but with another problem name.

 

When you select the Transfer option, a screen displays a list of available NeuroShell 2 files for the existing problem.

 

The Source Problem will default to the name of the current problem.  Use the File Menu to change the name of the source problem.

 

Use the File Menu to select the name of the Destination Problem, the one to which you want to transfer files.

 

When both a Source and Destination Problem are identified, you can use the mouse to check the names of the files you want to transfer to the new problem.  The new problem file names will be displayed on the screen.

 

Use the Transfer Menu to begin creating the new problem files.  Use the Interrupt Transfer option to stop the process.  

 

Edit Menu: This option allows you to Cut, Copy, and Paste data within the text edit box that displays the problem description.

 

Utility Menu:

Execute External Program: You may want to use an external program to generate data for use with NeuroShell 2, for example.  This option "shells out" to another program of your choice.

 

Print, view, or edit NeuroShell 2 internal files. These selections use NeuroShell 2 modules to do the printing, viewing, or editing.

 

Edit Text File with Notepad: This is a quick way of viewing a text file.  Use it to view ASCII files you want to import or ASCII files you have exported, for example.

 

Attach Internal Files: Use this option to combine or "glue" two files together.  You may want to use this option to create a single file that contains the network's training patterns (.PAT file) and the network's predictions or classifications (.OUT file).  The option may also be used to add new patterns to a training set of data.

 

Delete File: Use this option to erase a file.

 

Rename File: Use this option to change the name of a file.

 

Start Windows Explorer: Use this option to execute the Windows Explorer.

 

Restore Backed Up Pattern File: Before NeuroShell 2 modules Symbol Translate and Rules processes a file, a backup copy is made with a .OLD extension.  This option restores the old file in case you don't like the processing that resulted from Symbol Translate or Rules.

 

Options Menu

Minimize on New Module: This option will automatically minimize the existing windows when you double click on an icon to open a new module.

 

Set Background Color: This option allows you to select a different background color for the NeuroShell 2 module windows.  A color selection window is displayed that allows you to select either basic colors by clicking on a color square or custom colors by clicking on the Define Custom Colors button and using a mouse to move around a color spectrum box.

 

Select Datagrid:  This option allows you to select your own spreadsheet program rather than the NeuroShell 2 Datagrid as the data entry mechanism for NeuroShell 2. When you select this option, a selection window is displayed in which you choose the directory and .EXE file for your spreadsheet program.

 

If you choose to use your own spreadsheet program, you need to save the data file in .WK1 or Excel 4 .XLS format.  If your program contains label or column names that you want to use as NeuroShell 2 variable names, you need to create two range names.  Refer to the Spreadsheet Format section for details.  If you use the NeuroShell 2 Datagrid, the range names are created automatically.

 

Note:   The Datagrid was designed for use with small files only as it becomes slower and less efficient with large files.  If you are working with large files, we suggest using your regular spreadsheet.