GMDH Learning

GMDH Learning

Top  Previous  Next

 

Use the GMDH Learning module to train GMDH networks (learn the patterns in the training set). Start training from the Run menu.  Training continues until the criterion value reaches its minimum value, or until training is interrupted (see Modes of Interrupt below).

 

Note:  We realize that the explanation we have given for GMDH is brief, but a complete and detailed description of the algorithm is beyond the scope of this help file.  Readers interested in more technical detail should refer to Farlows book (listed in References).

 

Also, whenever the notation X^2 appears in the following documentation, it refers to X squared.  X^3 refers to X cubed, etc.

 

The criterion value is a numeric value which denotes the quality of the model.  You set the desired formula for the criterion value in the GMDH Advanced Training Criteria modules selection criteria block.  If you are using GMDH Smart Training Criteria, the criterion value formula (and all other algorithm parameters) are intelligently set by a combination of the selections you make in the GMDH Smart Training Criteria module.

 

The GMDH Learning module allows you to view graphics and statistics for both the training and test set patterns as learning progresses.

 

Training Graphics

The graphics in this module are meant for temporary use during training, because the graphics can greatly slow down learning.  Click on the icon to display the graph during learning.

 

Criterion Value Graphed By Layer Number

 

Statistics

Unlike all other NeuroShell 2 Learning modules, GMDH statistics are displayed without clicking any boxes, as the statistics are updated only at the end of each layer.  They are computed by applying the model to the training set and the test set if it is used by the Selection Criterion.  Refer to the section GMDH Advanced Training Criteria for more information.

 

The following statistics are available:

 

MSE (Mean Squared Error, defined in the Apply GMDH Network module.)

 

R Squared (Defined in the Apply GMDH Network module.)

 

Corr. Coeff. (Pearson’s Linear Correlation Coefficient r, defined in the Apply GMDH Network module.)

 

Norm. MSE This is the value of MSE normalized by the sum of squares of actual values. Such a normalized value gives one an opportunity to compare different problems with unnormalized outputs.  For some types of Selection Criteria, the value of normalized MSE allows you to estimate the complexity penalty for the obtained model.  The formula for Norm. MSE is the following:

 

Norm. MSE = sum [(act-pred)^2]/sum[(act)^2]

 

Refer to GMDH Advanced Training Criteria for more information.

 

Layer Construction Status

The current status of the layer being constructed is displayed using the statistics described below.  All of these statistics are updated automatically several times a minute.

 

Layer Construction Status - Displays a message describing the current stage of the layer.

 

Step Completion, % - Displays what portion of the current stage is complete.

 

Current Criterion - Displays the best criterion value achieved during training.

 

Time

Layer Time - Displays time elapsed from the beginning of current layer construction.

 

Total Time - Displays time elapsed from the beginning of the learning process.

 

Output Status

The results of the latest complete layer are summarized using the statistics described below.  These statistics are updated once after the completion of each layer.

 

Layers Constructed - Displays number of layers constructed.

 

Best Criterion Value - Displays the value of the criterion for the best model obtained at that layer.

 

Best Formula - Displays the total created model as a formula.  If the formula is too long, it will not fit on the screen.  Click on the arrow to scroll the box to see the entire formula.

 

Note 1: In this formula, numbers of the input variables are used instead of their names, as the names may be too long.  X1 refers to input number 1, X2 refers to input number 2, etc.  To translate the numbers of inputs into their names, select the Legend option from the Options menu.

 

Note 2: This formula is provided for qualitative estimations only.  It should never be used for predictions, as coefficients in this formula are intentionally without sufficient precision to allow you to reproduce the results.  If you use it, the results may sometimes not even be close!  If you want to apply the model to new data, use the Apply GMDH module.  If you want to use the model in your own program, use the Runtime Facilities.  Refer to Runtime Facilities for details.  (The formula displayed on the learning screen is limited to 1000 characters.  If you want to view a longer formula, use the Copy Results to Clipboard option from the File Menu and paste the formula into a notepad or spreadsheet.)

 

Most Significant Variables - Displays the input variables used in the winning model.

 

Less Significant Variables - Displays the input variables used in any of the Survivors except in the winning model.  All variables not mentioned in either of these dropdown boxes are insignificant and do not influence the output.

 

Note: Unlike the formula, the names of the variables are used in the variable lists. Const denotes a constant term, and any unnamed inputs are denoted as C1, C2, C3, etc. for inputs residing in columns number 1, 2, 3, etc. respectively.

 

When to Save the Network

As GMDH training continues, the result of each constructed layer is automatically saved if the criterion value is better (lower) than the previous layer.

 

Modes of Interrupt

Use the Run Menu to interrupt training.  As each GMDH layer may take quite a long time, there are several options for stopping training.

 

Terminate Layer Construction - (Enough For This One, Go On to the Next) - Select this option if you are satisfied with the results of the current layer and you want to stop checking further candidate models and move to the next layer.  Once selected, this menu item is checked and disabled, and the algorithm is forced to pass to the last stage of the layer.  However, it does not affect the decision as to whether training should proceed to the next layer.  Upon completion of such a terminated layer, training goes on as if the layer had ended without any user interference.  If the criterion value obtained during the terminated layer is good enough, the results of current layer are saved and construction of the next layer is started.  If the criterion value is not good enough, the training process ends.  (This option may be used together with Interrupt Training  - see below.)

 

Interrupt Training - (Let This Layer Be the Last One for Now) - Select this option if you want to stop training (usually temporarily) upon completion of the current layer.  You may use this option, for example, if you want to have different training parameters for different layers.  Note that choosing this option does not affect the progress of the current layer, which may continue for a long time.

 

Once selected, the Interrupt Training Menu item is checked but not disabled.  You may still continue training if you select this menu item once more.

 

Note:  The Terminate Layer Construction and Interrupt Training options work independently of one another.

 

You can instantly stop both the current layer construction and the training process simply by exiting the Learning module.  A message is displayed which tells you that the results of the current layer construction will be lost.  You will still have the saved results of the preceding layer construction, however, so you can continue training at a later time.

 

If training ends without user interference, it is not recommended that you continue training unless you change parameters in the Training and Stop Training Criteria module.

 

Note:  If you change the number of input or output neurons, you must retrain the network.  You cannot continue training the original network.

 

Use the File Menu to select a Configuration file.  The Copy Results to Clipboard option will copy the training results to the Windows clipboard.  You may then paste the results into a notepad or spreadsheet.  The GMDH formula displayed on the screen is limited to 1000 characters.  Use the Copy Results to Clipboard option if your formula is longer than 1000 characters to view the entire formula.

 

This formula is provided for qualitative estimations only.  It should never be used for predictions, as coefficients in this formula are intentionally without sufficient precision to allow you to reproduce the results.  If you use it, the results may sometimes not even be close!  If you want to apply the model to new data, use the Apply GMDH module.  If you want to use the model in your own program, use the Runtime Facilities.  Refer to Runtime Facilities for details.

 

Use the Options Menu to Show Legend and view variable names. This option shows which input and output names correspond to the variables used in the polynomial.  Usually, these inputs have been scaled, and the formula that was used to do the scaling is also shown.  The polynomial created by GMDH will assume that any variables have been scaled by these formulas.

 

File Note: This module defaults to training on a .TRN file, if it exists, or the .PAT file if there is no .TRN file.  This module uses the .FIG file created in the Design module and the .MMX file created in the Define Inputs and Outputs module.  All of these files for a given problem must reside in the same directory.