How to Use the Market Indicator Package

Top  Previous  Next

_bm44Market Indicator Package - Detail

The Market Indicator Package computes requested additional variables based upon different statistical calculations (indicators).  The new variables will be added to the right of columns in the pattern (.PAT) or production (.PRO) file when displayed in the Datagrid or a spreadsheet.  Indicators include moving average, percent change, lagged variables, etc.  Refer to Indicators for detailed information on each indicator.  Refer to the Optimizer for details on an option that selects the best indicators and/or parameters for your data.

 

The module may be used for any type of application in which raw time series data should be enhanced with indicators, and is especially useful for working with stock market and futures data.

 

Select File

The module defaults to using the .PAT file associated with the problem name.  Use the File Menu to select a different file or to view the file in the Datagrid.  Do not modify the file in the Datagrid or spreadsheet while using this module because the indicators will be added to the original file rather than the modified file.

 

Variable Selection

In the Variable Selection box, use the mouse to click on a variable which will be the basis for creating an indicator.  Only one variable may be chosen at a time.  Some indicators require supporting variables (see below).

 

Select Mode for the Variable

The Market Indicator Module allows you to create indicators in several different modes:   Standard, Stock, Futures1, and Futures2.  When a variable is initially selected, it becomes associated with the Standard Mode.  If you choose another mode for that variable, the variable remains associated with the last chosen mode.  Different indicators are displayed in the Indicator Selection box depending upon the mode.  In modes other than Standard, you will have an opportunity to select supporting variables because some indicators require more than one variable.  Also in different modes, different indicators appear in the selection list.  If you exit the module after applying the variables and then return, the module remembers the last selected mode for each variable.

 

Standard Mode: This mode requires that only one variable be selected from the Variable Selection box.  There are no supporting variables required for the indicators available in this mode.

 

Stock Mode: When this mode is selected for a variable, check boxes appear for the supporting variables High, Low, and Volume.  When you click on a check box beside a supporting variable, a drop down combo box appears that allows you to use a mouse to click on the variable from your data that contains the correct values.  Also, if you click one of these check boxes, more indicators will appear which require that variable.

 

For example, if you mark the check box for High, a combo box appears that allows you to select a variable from your file (e.g., Daily High) that contains the values you want to be used for High.  The supporting variable Close references the variable that is highlighted in the Variable Selection box.  In other words, the original variable is assumed to be a close.

 

It is not necessary to check all of the boxes for supporting variables that appear for each mode type.  Note that different indicators appear depending upon which boxes are checked.  However, to get access to all indicators possible in this mode, you should check the boxes for all supporting variables and select variables from the pattern file associated with the supporting variables.  This is because many indicators require multiple variables.

 

Futures1 Mode: Check boxes appear for supporting variables Open, High, Low, Volume and Open Interest.

 

Futures2 Mode: Check boxes appear for supporting variables Open, High, Low,  Call Volume, Open Interest (for Calls), Put Volume, and Open Interest (for Puts).

 

Select Indicator

After you have selected a variable mode and the corresponding supporting variable(s), you may select an indicator from the Indicator Selection box.  If the indicator desired does not appear, it requires additional variables that have not been selected.

 

Once you select an indicator, you need to enter values for corresponding parameters in the Parameters of Selected Indicator edit box. (Different parameters are displayed depending upon which indicator is selected.)  Enter the requested value(s) in the edit box(es).  For example, if you select Lag, you will be prompted to enter a value for the number of periods you want to lag the selected variable.

 

You have the option of entering multiple values in a specific parameter edit box. For example if you want to Lag a variable for 2, 3, 4, 5, and 10 periods, you may enter the values 2:5, 10 in the parameter edit box and the indicators Lag 2 of variable, Lag 3 of variable, Lag 4 of variable, Lag 5 of variable, and Lag 10 of variable will be created.

 

If you enter 2:8:2, the parameters would range from 2 to 8 in increments of 2, i.e., 2, 4, 6, 8.

 

Once you select an indicator and enter parameter values, click on the Add Indicator to End of Variables button to create the indicator and add it to the end of the Variable Selection box.  You may have to click on the scroll button to view the entire list.  Note that at this point, your data file will not have changed.  You need to select the Apply Indicators to Pattern File from the Apply Menu in order to change your data file.  You should do this only after adding all of the indicators you want, not after each one.

 

Edit Menu

Copy Indicator (from variable list) - Use this option if you have created an indicator that you wish to apply to another variable .  Use the mouse to highlight the existing indicator, select Copy Indicator from the Edit Menu, and then highlight another variable and use the Paste Indicator (to variable list) option to apply the indicator to another variable.

 

For example, if you create an indicator called MvAvg(2) of x, and wish to apply it to variable y, use the mouse to highlight the indicator MvAvg(2) of x in the Variable Selection box, then select Copy Indicator from the Edit Menu.  Next, select variable y from the Variable Selection box and then select the Paste Indicator (to variable list) option to create a new indicator called MvAvg(2) of y.  The new indicator will be added to the bottom of the Variable Selection box.

 

Paste Indicator (to variable list item) - This option works in conjunction with the Copy Indicator (from variable list) option to create the same indicator on multiple variables.  See Copy Indicator above for details.  You may also use this option to compound an indicator, for example MvAvg(2) of MvAvg(2) of x.  Use the mouse to highlight MvAvg(2) of x from the Variable Selection box, select Copy Indicator, and then select Paste Indicator from the Edit Menu.  The compounded indicator will be added to the bottom of the variable selection list.

 

Delete Item (from variable list) - Select this option from the Edit Menu to remove a variable from the Variable Selection box.  When you select the Apply Created Indicators to File option from the Apply Menu, the indicator will be removed from the current file, which is usually the .PAT file.  Note:  There must always be at least one variable present in the pattern file.

 

Copy All Attached Indicators  - Select this option if you have created several indicators based on one variable that you want to apply to a different variable.  This option may only be selected from the Edit Menu after you have created indicators based on an original variable.  To use this option, use the mouse to select the original variable used to created indicators, then select Copy Attached Indicators from the Edit Menu.  Next, use the mouse to select a new variable for these same indicators.  Next, select Paste Attached Indicators from the Edit Menu and the newly created indicators based on the new variable will be added to the bottom of the Variable Selection box.  For example, if you have created indicators based on variable X and want to apply the same indicators to variable Y, then use the mouse to highlight X in the Variable Selection box and select Copy Attached Indicators from the Edit Menu.  Next, use the mouse to highlight Y, then select Paste Attached Indicators from the Edit Menu.

 

Paste All Indicators - This option is used in conjunction with Copy Attached Indicators to copy previously created indicators to a different variable.  See Copy Attached Indicators for details.

 

Display Variable in Help Bar - Selecting this option displays the entire text for a selected variable in the Help Bar at the bottom of the screen. This may be useful because the names of the variables added by the indicator package can get very large.

 

 

Apply Menu

When you have finished creating and adding indicators, select the Apply Created Indicators to File from the Apply Menu.  The new indicators will be added in columns displayed on the right side of your existing data.  You may also use the Apply Menu to select Interrupt Apply to stop the process if you want to do so for any reason.

 

File Note:  If you examine your data file after you have created indicators, some cells may contain an asterisk.  If an indicator requires multiple patterns in order to be computed, an asterisk will be placed in the cells where insufficient data was in the file to compute an indicator.  For example, if you create an indicator that is a 5 day moving average of a variable, the indicator cell for the first 4 patterns in the file will contain an asterisk because the indicator could not be computed until 5 patterns were present.  NeuroShell 2 Training and Apply modules will not process any row in a data file that contains an asterisk in an input column because NeuroShell 2 presumes the row has insufficient data.  For the same reason, the Training Module will not process any row which contains an asterisk in an output column.  The Apply module will process any row in a data file that contains an asterisk in an output column, however.

 

Help Menu - Indicator Documentation

The individual indicators are documented in the online Help files.  If you are not familiar with an indicator, select one and then select Current Indicator from the Help Menu.