Viewing and Changing Weights in Link

Top  Previous  Next

Weights in Link

Use the Options Menu to Show Weights while a network is learning. (Backpropagation and Kohonen networks only.)  A screen of the network's slabs and links will be displayed that is similar to the one in the Design module.  Use the show option to examine or edit the actual weight values that exist on the link between neurons in one slab to neurons in another slab or to prune weights.  The weight values change as learning progresses.

 

Use the mouse to click on the scroll box to select either the Best or Last network in order to view the weights.  The Best network refers to the copy of the net that was saved when a new minimum average error was reached for either the Training or Test set, depending upon which was selected in the Learning module.  The Last network refers to the copy of the net at the current stage of training.

 

Use the mouse to click on the up and down arrows keys in the Link Number Selection Box to choose a link which contains the neuron values you want to examine.  The weights between neurons are displayed in a grid with the FROM neurons displayed across the top and the TO Neurons displayed down the side.  Weight values may be changed in the grid by either using the Edit Menu or double clicking on a single cell, entering a new value, and pressing enter to change the weight.

 

Allow Pruning: Click on this button if you want to prune or eliminate weights which have a value lower than the threshold that you type in the Pruning Threshold edit box.

 

Note:  You should interrupt training prior to using the pruning option.  If you plan on continuing training, you should use the Last network, otherwise the pruned weights will be overwritten.  If you prune the weights on the Best network, you should not continue training.

 

Although NeuroShell offers the capability of pruning weights, it is still better to use the Calibration feature to train a network which will generalize well on new data.

 

Refresh Weights: Click on this button to display the new weight values that are generated during training.  If you want the weights to stop changing, then interrupt training before you use this module.

 

Prune/Replace Weights: Once you have changed weight values or set a pruning threshold, click on this button to place the new weight values into the network or to prune weights if you have clicked on the Allow Pruning button.

 

File Menu

Export Network to ASCII file Use this option to write out the weight values in full precision for all links in either a backpropagation or Kohonen network.  This file is created with a .WTS extension.

 

Print Weights Use this option to print all of the weight values in the selected link.  You can print only selected weight values by using the mouse to blacken a range of cells.  When you select this option, a window will pop up that will allow you to click on check boxes to Print Column Headers, Print Row Headers, Print Border, and/or Print grid lines.  The window also allows you to type in measurements in inches for the top, bottom, left, and right margins. You can also print only selected cells by clicking on the mouse to blacken the cells.

 

Edit Menu The copy option allows you to cut, copy, and paste cells you select with a mouse to another cell or to a spreadsheet via the clipboard.

 

Hinton Diagram:

Use this Menu to display a colored Hinton Diagram of the network's weight values.  Advanced users may want to use these diagrams to view patterns in the weights.

 

Enable Option: The color display is activated when you select this option.

 

Highest Intensity Weight Option: This option allows you to specify the absolute weight value which will have the deepest color in the Hinton diagram.  For example, if you enter a 5, weights of 5 and above will display the deepest red colors and weights of -5 and below will display the deepest blue colors.  This option will allow you to show different gradations of colors.