Symbol Translate Input Files - Detail

Top 

_bm69Symbol Translate Input Files - Detail

Use this module to easily translate text (alphanumeric strings or symbols) into numeric values that the network is capable of processing. For example, you can use this module to translate "cold" to 0, "warm" to 1, and "hot" to 2.

 

For best results, translate the symbols into numbers that maintain the relative order of meaning for variable values.  In other words, don't translate warm to 0, cold to 1, and hot to 2 because the natural order that exists between the values would not be preserved.

 

If an order relationship between variables does not exist, the variables should be treated as separate input variables.  For example, if you had the variables north, south, east, and west, it would not be a good idea to translate them to 1, 2, 3, and 4 because the north isn't stronger (or weaker) than the west.  You should create four variables, one for each region, that is coded 1 for being in the region and 0 for not being in the region.

 

To use Symbol Translate:

1.  Click on the mouse to position the cursor beneath the "Find this text" column. Type in the text (alphanumeric data) that you wish to translate. Strike enter to complete the edit.

2.  Click on the mouse to position the cursor beneath the "Translate to value" column. Type in the numeric value the Symbol should take and strike Enter.

3. Click the mouse to position the cursor beneath the "Translate in These Variables (Columns):" column.  Choose the column(s) where the translation should take place by clicking on the appropriate variable(s) from the Variable/Column List box.

4. Repeat the above procedure for each text value in the file that you wish to translate. For example, if the variable temperature could take on the values cold, warm, and hot, you would enter separate lines in the symbol translate table for the text cold, warm, and hot.

 

The Symbol Translate Module allows you to translate up to 10 columns in a single data file.

 

Use the File Menu to select a different file or to view your data file.

 

Select the Translate Menu to interpret the file once you have completed the translate table. This menu includes an option to interrupt translation.

 

Use the Edit Menu to cut, copy, or paste a cell, to insert or delete rows, or to clear the symbol table.

 

Expand column width by dragging the bar that separates column names.

 

You will be asked if you want to save the symbol translate table before exiting the module.  If you save it and then later return to the module in this problem, the information you entered will still be there.

 

File Note: When applying Symbol Translate to data before it is processed by the neural network, NeuroShell 2 defaults to using the .PAT file.  Use the File Menu to select another file.