Symbol Translate Output Files - Detail

Top 

_bm70Symbol Translate Output Files - Detail

Symbol Translate may be used on the network's output file (.OUT) to translate numeric data into symbols.  For example, if you have a sales prediction system where the network's outputs are 1 and 0, you may want to translate 1 to a string that says "Likely sale" and translate 0 to a string that says "Unlikely sale."

 

To use Symbol Translate:

1.  Click on the mouse to position the cursor beneath the "Find this value" column. Type in the numeric value that you wish to translate. Strike enter to complete the edit.

2.  Click on the mouse to position the cursor beneath the "Translate to this text" column. Type in the text the numeric value should be interpreted as and strike Enter.

3. Click on the mouse to position the cursor beneath the "Translate in these variables" column.  Choose the column(s) where the translation should take place by clicking on the appropriate variable from the Variable/Column List box.  The text will replace the numeric value in the selected column(s).

4. Repeat the above procedure for each numeric value in the file that you wish to translate. For example, if the variable has 3 numeric values, you need to enter a text value that corresponds to each numeric value.

 

The Symbol Translate Module allows you to translate up to 10 columns in a single data file.

 

Use the File Menu to select a different file or to view your data file.

 

Select the Translate Menu to interpret the file once you have completed the translate table. This menu includes an option to interrupt translation.

 

Use the Edit Menu to cut, copy, or paste a cell, to insert or delete rows, or to clear the symbol table.  Expand column width by dragging the bar that separates column names.

 

You will be asked if you want to save the symbol translate table before exiting the module.

 

File Note: When applying Symbol Translate to data after it is processed by the neural network, NeuroShell 2 defaults to using the .OUT file.  Use the File Menu to select another file.